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Release History 
This document lists changes made to the SWIFT-Review application. Please send your requests for new 

features and/or report any problems to swift-review@sciome.com! 

Version 1.43, Build 10597: 11.15.2023 

SWIFT-368: Updated to latest log4j-2.21.1 
Updated the log4j library to latest version 2.21.1 

SWIFT-367: Fixed RIS upload when there are KW field with “|” in 
values. 
Fixed the bug where a RIS file having KW field with “|” in the values were not being imported to SWIFT-

Review. 

Version 1.43, Build 10588: 04.13.2023 

SWIFT-366: Import custom Tag-Category bug fix. 
Fixed the bug where custom tag-categories in RIS file were not being imported to SWIFT-Review. 

Version 1.43, Build 10588: 04.10.2023 

SWIFT-365: Included Topic Model in set of default tag categories 
at start of the project. 
User has the option to select/unselect the topic model tag category to be run while creating the project from 

ris/csv file. 

Version 1.43, Build 10580: 11.18.2022 

SWIFT-364: Parse affiliation and funding from RIS and make 
them searchable 
If the imported RIS file has affiliation (AD) and/or funding (FU) keywords, SWIFT-Review will parse it and 

make the searchable by key words, affiliation and funding. 

SWIFT-360: Send labels through ActiveScreener API 
If label field is available for the references uploaded via RIS file, they will be preserved and will also be passed 

to ActiveScreener when “Send to ActiveScreener” option is used. 

mailto:swift-review@sciome.com
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/ff30f3506fcc5916f2bcdd20554436309b014004
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SWIFT-358: Skips multiple re-indexing when edition tags 

SWIFT-354: Updated ActiveScreener API 
Updated API to improve the speed of accessing ActiveScreener projects. 

SWIFT-346: Option to select tags to be run when building a new 
project 
There is an option to select which default tag categories to be calculated when building a new project.  

SWIFT-356: Upload tags from uploaded RIS 
The uploaded RIS file will be parsed to identify the Swift-Review’s default tag categories in it. It will allow user 

to either use the tags from the uploaded RIS file or recalculate them. 

 

Version 1.43, Build 10535: 02.02.2022 

SWIFT-355: Normalization of the text 
When a new project is creates, text of title and abstract will be normalized to remove certain special 

characters. 

SWIFT-354: Updated Active Screener API endpoint to access the 
AS projects 
Reduced the time taken to access the Active Screener project(s).  

SWIFT-352: Fixed tagging of mesh_SH with mesh_code 
Fixed a bug where mesh_code was incorrectly tagged under mesh_SH 

SWIFT-350: Show search strategies web link instead of pdf 

SWIFT-349: Changed encoding to UTF-8 when reading files 
during batch query 
When tag files are uploaded via batch query tool, the files will be encoded to UTF-8 to ensure the normalized 

text. 

http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/ff30f3506fcc5916f2bcdd20554436309b014004
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/6b204b6fc6fae4467d585ddeed3462390a10a6f9
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/6b204b6fc6fae4467d585ddeed3462390a10a6f9
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/ad4f51f97191ca282c6f1563c0942361a793ff23
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/a659be24de505f3de1cbee41e2beec977ba95176
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/7bf466c90132386a6420f1493561654251b0aac1
http://192.168.167.103:7990/bitbucket/plugins/servlet/jira-integration/issues/UTF-8
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/7bf466c90132386a6420f1493561654251b0aac1
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/7bf466c90132386a6420f1493561654251b0aac1
http://192.168.167.103:7990/bitbucket/projects/SWIF/repos/swift-review/commits/7bf466c90132386a6420f1493561654251b0aac1
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Version 1.43, Build 10533: 04.16.2021 

SWIFT-341: Updated StringTokenizer to split the search term 
with hyphen and lower case it 
Fixed the bug where the Upper-case query with hyphen and wild card won't return any hits. 

Version 1.43, Build 10518: 02.22.2021 

SWIFT-340: Include new Tag Category called “EPA Exposure and 
Fate" 
Added a new tag category in default tag category list. 

Version 1.43, Build 10515: 12.01.2020 

SWIFT-339: Reordering of tags 
Fixed the broken reordering of the tags. 

SWIFT-335: Import NBIB file 
Resolved the issue related to uploading of NBIB file having book chapter(s). 

Version 1.43, Build 10508: 06.01.2020 

SWIFT-336: Export tag category and tag names in exported RIS file 
User can export the tag categories and tag names in RIS file. The information will appear in KY field. The tag 

category and tag names will be separated by “|”.  

SWIFT-336: Saving more keywords from RIS file  
Processing and saving more information from the imported RIS file, like SN, CN, M3, Custom fields etc.  

SWIFT-335: Import NBIB file 
The new NBIB format( from PubMed) is supported. 

Version 1.43, Build 10499: 05.11.2020 

SWIFT-334: Clean tags by number of hits 
Tags can be removed if the number of the tagged references fall below the user defined threshold value. 
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Version 1.43, Build 10456: 08.28.2019 

SWIFT-326: Add “Environmental Fate” as new default tag 
category 

SWIFT-325: Add RIS ID in tab delimited and excel export option 
References can be searched by RIS ID using ‘risid’ as the keyword in the search query. 

SWIFT-324: Allow to search RIS ID in search field 

Version 1.43, Build 10455: 08.26.2019 

SWIFT-323: Save ID value from RIS file 
A RIS file can be generated from multiple sources/tools and then can be imported into SWIFT-Review. The ID 
keyword in RIS file can represent the unique value generated from source/tool or some other value. SWIFT-
Review saves this value and shows the value in document preview panel. Also, the same value can be 
exported back when user selects RIS format and “Original RIS ID” as the identifier. 

SWIFT-322: Clean old tag categories when repository has 
renamed one 
The renaming of the Sciome-default tag categories/tag names was not replacing the old ones from the local 
system of the user. User had the renamed one (after the launch of SWIFT-Review), but also had the older 
ones, which could cause confusion. 
The issue is fixed by deleting the local tag categories folder’s content and then replacing by updated content 
from the repository, during launch of SWIFT-Review. 

Version 1.43, Build 10454: 06.24.2019 

SWIFT-321: Advanced option to select RIS format 
While exporting RIS file from SWIFT-Review, user would have option to select an identifier to use in the ID 

field of the RIS file. The options are either to select SWIFT ID, incremental ID or HERO ID, if available.  

Version 1.42, Build 10434: 01.04.2019 

SWIFT-315: Bug: Load PMID list text file 
Since Dec 1 2018, NCBI has enforced the use of API key to post the requests to the E-util. Without the API 

key, NCBI was rejecting the requests posted by SWIFT-Review in order to pull the information about upload 

PMIDs. We are now using API key as per the NCBI guidelines. 
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SWIFT-313: Reduce number of API calls during the launch 
During the launch of SWIFT-Review, each of the required resource files, tag categories were getting checked 

if there was any update. For each file, it was making one call which was causing severe load on Sciome server. 

We have now reduced the number of API calls significantly.  

Version 1.41, Build 10429: 12.18.2018 

SWIFT-312: Save and export URL keyword in RIS 
We are saving the URL information, if available, in imported RIS file from HERO. The URL information is also 

printed out in generated RIS file from SWIFT-Review which can be exported to Distiller and Active Screener. 

Version 1.40, Build 10415: 09.10.2018 

SWIFT-311: Bug: Empty excel sheet when export the duplicate 
references list after exporting references to Active Screener 
We have fixed the issue where an empty excel file was generated, instead of list of duplicate references, 

when references were exported to Active Screener, keeping the de duplication checked. 

SWIFT-310: Bug: Missing queries in tag category explorer 
We have fixed the issue when a query would disappear from tag category explorer, after its edit/update.  

Version 1.40, Build 2155: 05.10.2018 

SWIFT-231: Store index on disk and improved indexing speed 
Previously, it could take several minutes to load projects, especially large ones. Although we have greatly 

decreased load times since the original release, a remaining bottleneck is caused by SWIFT-Review needing to 

rebuild the search index every time the application starts. In this latest release, this has been somewhat 

ameliorated by changing to a disk-based index rather than a completely in-memory index. 

Indices are automatically saved in project-specific directories in the user data directory.  If those file-based 

indices are not already present, they are generated at the time of loading a project.  This would ordinarily 

happen the first time a project is loaded, created, etc.  If the indices are found, they won’t be generated 

again. For improved performance, the disk-based indices are loaded into memory during usage of the 

application; the index is then re-written to disk when the project is saved. 

In case the index ever becomes corrupted for some reason, the menu selection Tools > Options > Index, 

gives the user the option to recreate the index files, from the current state of the project. 
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SWIFT-285: Allow user to remove references from existing 
project 
It is now finally possible to remove references from an existing project. 

 

SWIFT-242: Tagging: multiple operations at once 
The manual tagging procedure has been stream-lined. It is now possible to add and remove multiple tags at a 

time from a selected set of documents. (Previously, tags could only be added and removed one-at-a-time.) 
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SWIFT-256: Reduce need for full install during updates 
We have made certain improvements that should make it less likely that a full installation is needed during 

future updates.  (See the discussion on Minor Updates versus Major Updates in the User Guide.) 
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SWIFT-283: Better way to customize built-in queries 
We have added a new feature that allows users to more easily explore and modify the built-in tagging 

mechanism. Users can click Tools > Tag Category and Query Explorer to view and edit the built in tagging 

queries and create their own customized versions.  Users can also choose to make their search strategies 

“public” in order to share them with other interested users. 

 

SWIFT-287: Chemical synonym tool improvements 
We have made the following minor improvements to enhance the user experience with chemical 
synonym tool: 
 

1. On completion, set the progress to 100%. Previously, it stopped at 99%. 

2. The summary window is now scrollable. 

3. The "tag category" text field is now disabled while running batch query. 

4. Wait mouse cursor is now shown while running batch query, building query, etc. 

SWIFT-286: Hero Import: minor improvements 
The following changes have been implemented to improve the user experience with HERO import: 

1. We now show the name of the importing project in progress bar window. 
2. There is now an option to cancel the import. 
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3. On refresh button click, the software now confirms with user again if he really wants to 
refresh. Sometimes, the button can be clicked by accident and user would have to wait 
unnecessarily till it downloads the latest file. 

SWIFT-264: File format check 
When importing text files, software should now check to see if it looks like a PMID List or RIS and provide and 
error message to user, if selected format doesn't match. 

SWIFT-254: Include tags with count zero in batch query 
Previously if one of the queries resulted in zero hits, no new tag was created. So, the only tags that were 

created were for queries that result in one or more hits. There is now an option to create new tags even for 

empty result sets: 

 

SWIFT-304: Option to specify items as training file when 
importing 
You can now specify training documents using an RIS file or PubMed XML file (in addition to the previous 

method of using a CSV file).  Note that for these two new options, the selected references must already have 

been loaded into the project itself.  
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After you select the file, the software will ask you whether you want the items to be considered as “Included” 

or “Excluded.” 

 

In this way, you can repeat the procedure twice to upload your “Included” and “Excluded” training set from a 

pair of corresponding RIS / PubMed XML files. 

SWIFT-305: New export format 
When exporting documents from the Document List (Right-click > Export Document List), there is now a new 

file option: “Research Information Systems Citation File for Distiller (.ris).”  This was added due to a bug in 

Distiller whereby SWIFT IDs having an initial “s” character where not recognized properly.  When this is 

chosen, the SWIFT IDs are replaced so that they are compatible with Distiller. 

SWIFT-306: Bug: missing a reference when merging two RIS files 
Occasionally, when loading a new RIS file and choosing to “merge” the results with the existing project, a 

single reference could sometimes be omitted. 

 

SWIFT-300: Add Splash Screen 
When SWIFT-Review loads, users will now see a “Splash Screen.” 
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Version 1.30, Build 1769: 11.13.2017 

SWIFT-296: Add Third Level to Heatmap Browser 
In response to a user request, we have included the option to show an additional nested column category in 

the Heatmap Browser.  When choosing Rows/Columns to display, if you leave the “Use Category 3” checkbox 

unchecked, the heatmap browser will behave exactly as before.   

 

However, if you do check this checkbox, additional options will be displayed: 
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Here the user has elected to display Health Outcomes in the rows and Topic Models and Exposure in the 

columns, with Exposure (Category 3) shown nested within Topic Models.  The resulting heatmap looks as 

follows: 

 

Note that each topic model is shown at the top of the screen, and within each possible topic model, 

exposures are shown as individual columns. Hence, the upper left square containing the number “2” 

indicates that there are 2 documents having the following combination of tags: 

- Health Outcome: “Cancer” 

- Topic Model: “Topic 0” 

- Exposure: “Air Pollution” 

Since some Tag Categories can contain thousands of individual tags, you must carefully choose the tag 

categories to display when setting up a 3-level heatmap.  For example, since the Tox21 Chemicals category 

contains approximately 9000 tags and the EDC Chemicals category more than 1000 tags, naïve selection of 

these two tag categories could result in a heatmap with more than 9 million columns!  For this reason, we 

have provided the ability for users to specify not just a Tag Category, but also specific tags within that 

Category for display.  In the following example, the user has elected to show only 4 chemicals from the Tox21 

Chemicals category: 
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SWIFT-298: Allow user to omit the [No Tag] category in 
Heatmap Browser 
By default, the [No Tag] category is omitted from the heatmap browser display, unless the user specifically 

requests to include it. 

 

SWIFT-297: Option to Show Circles Instead of Colors in Heatmap 
Browser 
We have included a new visualization in the heatmap browser.  Users may now elect to display circles of 

varying size in lieu of the traditional color gradient: 
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SWIFT-221: Export of Tag Assignments and percentages 
We have provided some additional functionality with regards to exporting data from SWIFT-Review.  Now 

when you export a list of references from the Document List, you can also elect to export specific Tag 

Category assignments and the associated percentages in a variety of formats.  First, choose “Export 

Document List…” from the right click menu: 
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Specify a Filename and select a document scope: 

 

To specify advanced formatting settings and select specific Tag Categories for export, click “Advanced 

Options.” 
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The default output format is one row per reference as follows: 

Note that in this format there is a single line per reference and the individual MeSH and Supplementary 

Chemical tags are shown within a single column, separated by the “|” character.  

If the user instead chooses the format “One row per Cartesian product of tag category(s)”, the first row in the 

above output is expanded as follows: 

 

In this case, the single row for PMID 11457658 is expanded to 312 separate rows containing every possible 

combination of the assigned MeSH Heading and MeSH Supplementary tags.  At the bottom of the screen is a 

checklist that allows you to specify the specific Tag Categories you would like to include in the output.  Be 

very cautious about your choice of Tag Categories when using the Cartesian product output format, as the 

resulting number of rows can increase very quickly. 

SWIFT-290: Make PMID counts clickable in Chemical Synonyms 
Results List  
If you select “Count Hits in PubMed” when running the Find Chemical Synonyms tool, the resulting hit count 

will be displayed as a clickable hyperlink.  Clicking this link takes the user to the PubMed website to view the 

corresponding search results. 

 

Score Training Item? Included? RefID HeroID Title Abstract Year Authors Journal Database Accession NumberMeSH Heading MeSH Supplementary Chemicals

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Animals|Antineoplastic 

Agents|Calcitriol|Calcitriol|Creatine 

Kinase|Creatine Kinase, BB 

Form|Diaphyses|Diaphyses|Drug 

Interactions|Enzyme Induction|Estradiol|Growth 

Plate|Growth 

Plate|Isoenzymes|Male|Osteoblasts|Osteoblasts

|Rats|Rats, Wistar|Receptors, Estrogen|Selective 

Estrogen Receptor Modulators|Steroid 

Hydroxylases|Steroid Hydroxylases|Tumor Cells, 

Cultured|Up-Regulation|Vitamin D

Antineoplastic Agents|Isoenzymes|JK 1624F2-

1|Receptors, Estrogen|Selective Estrogen Receptor 

Modulators|Vitamin D|Estradiol|Steroid 

Hydroxylases|vitamin D 1-alpha hydroxylase|Creatine 

Kinase|Creatine Kinase, BB Form|Calcitriol

0.0 false false 6263596 Dissociated changes of pituitary luteinizing hormone-releasing hormone (LHRH) receptors and responsiveness to the neurohormone induced by 17 beta-estradiol and LHRH in vivo in the rat.A single injection of 17 beta-estradiol into castrated male or female rats results in an initial decrease in plasma concentrations of LH and pituitary responsiveness to LHRH, followed by a rapid return to normal or slightly elevated values. Under such experimental conditions, no acute change of binding of [125I-labeled D-Ser(TBU)6]LHRH ethylamide to anterior pituitary homogenate could be observed. Moreover, the self-priming effect of LHRH, as illustrated by a 10-fold increase in the LH response to a second injection of LHRH in the afternoon of proestrus, is accompanied by a 40% loss of pituitary LHRH receptors. During the estrous cycle, a 100% increase in pituitary LHRH receptors is already found on diestrus II, while the maximal LH responsiveness to LHRH occurs later, namely on the afternoon of proestrus. The present findings of a dissociation between changes in LHRH receptor levels and LH responsiveness to the neurohormone suggest that postreceptor events play a predominant role in the control of gonadotrop1981 Ferland L, Marchetti B, Séguin C, Lefebvre FA, Reeves JJ, Labrie FEndocrinologyPubmed 6263596 Animals|Castration|Estradiol|Female|Gonadotro

pin-Releasing Hormone|Gonadotropin-Releasing 

Hormone|Kinetics|Male|Pituitary Gland, 

Anterior|Pituitary Gland, 

Anterior|Rats|Receptors, Cell Surface|Receptors, 

Cell Surface|Receptors, LHRH

Receptors, Cell Surface|Receptors, LHRH|Gonadotropin-

Releasing Hormone|Estradiol

0.0 false false 446400 The effects of 17 beta-estradiol on progesterone secretion by bovine theca and granulosa cells.1979 Fortune JE, Hansel WEndocrinologyPubmed 446400 Animals|Castration|Cattle|Estradiol|Female|Gra

nulosa Cells|Granulosa 

Cells|Kinetics|Progesterone|Theca Cells|Theca 

Cells

Progesterone|Estradiol

Score Training Item?Included? RefID HeroID Title Abstract Year Authors Journal Database Accession NumberMeSH Heading MeSH Supplementary Chemicals

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Animals Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Antineoplastic AgentsAntineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Calcitriol Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Calcitriol Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Creatine Kinase Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Creatine Kinase, BB FormAntineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Diaphyses Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Diaphyses Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Drug Interactions Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Enzyme Induction Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Estradiol Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Growth Plate Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Growth Plate Antineoplastic Agents

0.0 false false 11457658 A non-calcemic analog of 1 alpha,25 dihydroxy vitamin D(3) (JKF) upregulates the induction of creatine kinase B by 17 beta estradiol in osteoblast-like ROS 17/2.8 cells and in rat diaphysis.We have reported that multiple treatments with so-called 'non-hypercalcemic' analogs of 1 alpha,25(OH)(2) vitamin D(3) (1,25(OH)(2)D(3)) stimulate the specific activity of creatine kinase BB (CK) in ROS 17/2.8 osteoblast-like cells, and that pretreatment with these analogs upregulates responsiveness and sensitivity to 17 beta estradiol (E(2)) for the induction of CK. However, since the analogs showed toxicity in vivo, we have now studied the action of a demonstrably non-calcemic hybrid analog of vitamin D in ROS 17/2.8 cells, and prepubertal rats. The analog JKF was designed to separate its calcemic activity from other biological activities by combining a calcemic-lowering 1-hydroxymethyl group with a potentiating C, D-ring side chain modification including 24 difluoronation. Treatment with 1 pM JKF alone significantly stimulated CK specific activity at 4 h by 30+/-10%. However after three daily pretreatments, JKF upregulated the extent of induction by 30 nM E(2) by 33% at 1 pM and by 97% at 1 nM; the E(2) do2001 Somjen D, Waisman A, Lee JK, Posner GH, Kaye AMThe Journal of steroid biochemistry and molecular biologyPubmed 11457658 Isoenzymes Antineoplastic Agents
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Version 1.30, Build 1695: 9.18.2017 

SWIFT-295: Add publication year option to heatmap browser 
In the heatmap browser, you can now choose “Publication Year” for the columns.  

 

If you do so, extra options will appear to allow you to select the date range and the bin size: 

 

The result is an interactive, browsable version of the “Publication Year Heatmap” report. 
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Version 1.30, Build 1671: 8.21.2017 

Bug Fix Release 
This release fixes a few recent bugs: 

• SWIFT-291: Edit Tags Problem 

• SWIFT-292: Merge Hangs 

• SWIFT-294: Chemical synonym tool issue 

Version 1.30, Build 1634: 8.07.2017 

SWIFT-279, 280: Integration of SWIFT-Review with HERO 
Database 
SWIFT-Review now includes a feature that will allow you to import documents directly from EPA’s HERO 

database.  From the File menu, choose “Import from HERO”: 

https://hero.epa.gov/hero/
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You will be presented with a list of HERO projects / usages.  (The window that is shown should have a similar 

appearance to the plugin created by the HERO team for data import into End Note.) 

 

 

Simply select the project you would like to import and press the “Import” button. After the data has been 

imported, SWIFT-Review will use the HERO ID plus the prefix “h” as the Reference ID for each reference.  

 

In addition, the software will also keep track of the original HERO ID for each reference.  For example, if you 

later export the data to an Excel or RIS file, the original HERO IDs will be retained.  For RIS files, the HERO ID 

will appear in the “LB” (Label) field of the file. 
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SWIFT-275: New Heatmap Browser in SWIFT-Review GUI 
We have added a new Navigation Pane to SWIFT-Review.  The new Heatmap Browser allows you to choose 

two Tag Categories and to create an interactive heatmap highlighting co-occurrences of each pair of tags 

from the two selected tag categories.  For example, in the image below, the user has selected the Tag 

Categories “Health Outcomes” and “Topic Models.” 

 

Clicking any cell in the heatmap will filter the visible documents to the corresponding subset of the 

documents.  In the example above, the user has clicked the cell for the health outcome “Cancer” and topic 

model 0; as a result, SWIFT-Review filters the documents to display only the 181 references having both 

health outcome tag Cancer AND which belong to topic model 0.   

To change the Categories shown in the heatmap, simply click “Choose Rows/Columns…” in the upper right 

corner of the heatmap.  You will see a window that allows you to change the categories: 
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In addition, you can also (optionally) specify a “pre-filter” to apply to the dataset.  For example, to refine the 

results to show the heatmap data, but ONLY for documents having the Evidence Stream tag of “Animal,” click 

the “Pre-Filter” button and specify the following query: 

 

SWIFT-278: New Publication Year Report 
We have added a new report that allows you to create a heatmap that bins publications by publication year 

within a given Tag Category. 

 



  Page 22 of 53 

For example, to create a heatmap showing a heatmap of the number of documents for each Health Outcome, 

by decade, simply choose the following choices from the available options: 

 

The result is an Excel file containing a heatmap similar to the following: 
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SWIFT-257: Chemical Synonyms Tool 
We have added a new tool that allows users to build SWIFT-Review and PubMed queries that target 

literature for specific chemicals.  The tool takes as input a list of chemical names and/or CAS numbers and 

outputs a query that incorporates various synonyms for those chemicals.  The chemical synonym names were 

computationally curated from the ChemIDPlus database using a procedure described in the SWIFT-Review 

manuscript.   

To use this feature, select Tools > Find Chemical Synonyms… 

 

You should see a window that looks similar to the following.  You can either upload a file containing a list of 

CAS Numbers and/or Chemical names, or you can type them in manually as shown below.   

 

After clicking “Submit” you will be presented with a results list containing PubMed and SWIFT-Review queries 

as shown below.  If you clicked the “Count Hits in PubMed” checkbox, there will be an additional column 

containing the number of references found in PubMed to match the query. 

https://systematicreviewsjournal.biomedcentral.com/articles/10.1186/s13643-016-0263-z
https://systematicreviewsjournal.biomedcentral.com/articles/10.1186/s13643-016-0263-z
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From here, you can right click to copy the data to the system clipboard, or you can choose “Export” to send 

the results to an Excel File.  In addition, if you would like to automatically tag the SWIFT-Review documents in 

the current project using the resulting queries, simply choose the “Batch Query” option at the bottom of the 

screen. 

SWIFT-33: Ability to add new documents to existing project 
If you already have a project open in SWIFT-Review and then attempt to open another project or load 

additional data, you will now see a prompt similar to the following: 

  

If you choose “Replace,” SWIFT-Review will simply close your current project and load the new data. On the 

other hand, if you choose “Merge,” SWIFT-Review will append the newly loaded references to the current 

project.  In some cases, for example when multiple PubMed or HERO projects are loaded, it may be the case 

that certain references exist in both datasets.  When possible, SWIFT-Review will attempt to identify such 

cases so that the resulting project does not contain duplicates.   

In addition, when possible, the software will attempt to merge tags.  Sometimes, this can lead to unusual 

results if, for example, the original project was tagged using an older version of one or more tagging 

procedures.  In such cases, you can always re-tag the documents in SWIFT-Review (Tools > Reset Automatic 

Taggers…) 

When the data load is complete, you should see a new Tag Category in SWIFT-Review called “Document 

Imports.”  Here you will find new tags that can be used to quickly identify the set of original documents as 

well as the ones that were newly added.  
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  Page 26 of 53 

SWIFT-247, 248: Allow users to delete, rename and reorder tag 
categories 
Users can now delete, rename and modify the Tag Categories.  Simply right click in the blank area at the top 

of the Tag Browser and choose “Edit Tag Categories” from the resulting menu: 

 

You will see a window similar to the following.  Note that certain tag categories such as MeSH Terms, etc are 

not allowed to be changed. 
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SWIFT-281: Bug Fix – Send to Active Screener issue 
We have fixed an issue that sometimes prevented the “Send to Active Screener” functionality from working 

properly. 

SWIFT-273: Bug Fix – asks to save when nothing changed 
Previously, upon closing, the software would always prompt the user to save their changes even when 

nothing had changed.  This issue has been fixed. 

Version 1.22, Build 1544: 3.17.2017 

SWIFT-272: Add ability to include punctuation in search 
Normally SWIFT-Review removes punctuation before searching.  This is so that searching results are not 

affected by things like periods at the end of sentences, quotation marks, commas, etc.  However, in order to 

support search for targets like “p <”, we have added some additional search fields that retain punctuation: 

tiab_punct, title_punct, abstract_punct.  Now, if you want to search for “p <”, you will may use syntax like 

this: 

tiab_punct:( “p <” ) 

1.21, Build 1530: 2.16.2017 

SWIFT-270, 269, 268: Improve Queries in Response to Manual 
Tagging 
The SWIFT-Review Health Outcomes, Evidence Stream and Characteristics of Cancer filters were modified in 

response to a round of manual tagging and review conducted at NIEHS.  In addition the Health Outcomes 

categories were modified to more closely align with labels used within the organization.  The new queries are 

expected to have higher recall, but lower precision.  A decision was made to emphasize recall over precision 

since it may be important not to miss important articles.  Overall specificity is still high. 

The new queries will be automatically applied to new projects.  For existing projects, re-tagging is optionally 

available via the command Tools > Reset Automatic Taggers… 

SWIFT-263: RIS Export Changes 
Minor changes were made to the “Export as RIS” feature to accommodate certain unusual cases and to 

better conform to file format conventions. 
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Version 1.20, Build 1296: 9.26.2016 

SWIFT-262: Update NCBI API calls to use https 
NCBI has changed from http to https.  This required internal changes to SWIFT-Review API calls.  More info 

available here: https://www.ncbi.nlm.nih.gov/home/develop/https-guidance.shtml 

SWIFT-141/251/252: Support for Non-PubMed articles and RIS 
Import 
It is now possible to load titles and abstracts from sources besides PubMed.  You may now import any file in 

RIS format: choose File > Load Text File… and select “Research Information Systems Citation File (*.ris)” in 

the “Files of Type” dropdown.  (Support for the Bibtex record format and EndNote XML will come in a future 

update). 

 

Each record imported will be assigned a unique “SWIFT ID.”  For records originating from PubMed, this will 

simply be the standard PMID.  For other databases, a unique key will be assigned automatically.  You can see 

the SWIFT ID at the bottom of the Document Preview window: 

https://www.ncbi.nlm.nih.gov/home/develop/https-guidance.shtml
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Also shown are the original database, if provided in the import file, and the original accession number.  In this 

case, the record originated from Web of Science.  Also note that SWIFT-Review does not perform record de-

duplication, so this step should be performed prior to importing. 

SWIFT-260: Search strategy details accessible from Help menu 
Now you can choose Help > Search Strategies to view a document that contains the details of the search 

strategies used for various SWIFT-Review tags 

SWIFT-261: Characteristics of Cancer tags 
We have included new tags for Characteristics of Cancer.  Details can be viewed under Help > Search 

Strategies. 

SWIFT-249/259: Updated Health Outcome queries 
We have updated the search strategies for the SWIFT-Review health outcomes to better align with the health 

outcome categories used at NIEHS.  In addition, for articles that do not have associated MeSH terms, title and 

abstract terms derived from text-mining are used instead.  Details for the Health Outcomes search strategy is 

available online from the help menu: Help > Search Strategies. 

SWIFT-239: Byte Order Markers 
In certain case files (such as PMID Lists, RIS files, etc) that are exported from other programs including 

EndNote may contain an initial series of special characters called “byte order markers.”  These characters, 

which may be invisible in an ordinary text editor, are supposed to be used to indicate details of the character 

encoding used in the document.  When present, these characters were previously causing problems during 

import into SWIFT-Review.  This problem has been fixed. 
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SWIFT-79:  Shuffle command 
In some cases, it can be helpful to have a randomized list of articles in your project.  For example, you may 

need a random sample to build a training set for machine learning, or you may be interested in validating the 

precision and recall of a custom query in SWIFT-Review.  To “shuffle” the currently displayed articles in 

random order, right click in the document list and choose the shuffle command: 

 

SWIFT-250: Active Screener Integration (beta) 
If you have access to the beta version of SWIFT-Active Screener, then you can now export articles directly 

from SWIFT-Review to SWIFT-Active Screener. 



  Page 31 of 53 

 

SWIFT-244: Add test set curve to ranking performance 
The Recall curve shown for prioritized lists now includes a separate curve for items in your “test set.”  The 

test set is defined by checking “Included?” for a set of known relevant items, but not checking the “Training 

Item?” box for those same items.  The test set performance can provide a more realistic estimate of the 

expected performance on the remaining unlabeled items. 

 

SWIFT-127: Ranker: auto-balance training items with under-
sampling 
Previously, users were advised to select an equal number of positive and negative instances when training a 

machine learning model.  Now, in order to simplify the process for users, SWIFT-Review will use under-
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sampling to automatically balance the items in the training set.  Thus, it is no longer necessary to select equal 

numbers of positive and negative items 

SWIFT-258: Built-in batch query causing [No Tag] counts to be 
wrong 
In a few unusual cases, the displayed count for [No Tag] in SWIFT-Review could be incorrect. This has been 

fixed. 

SWIFT-240: Limit Length of displayed tag names in bar chart 
In certain scenarios, very long tag names could previously cause problems in the bar chart display.  To 

prevent this, users can now specify the maximum length for bar chart labels in the SWIFT-Review 

preferences: 

 

SWIFT-246: Bad mesh term query bug 
Previously, if a SWIFT-Review query uses the field mesh_mh and the mesh term queried does not actually 

exist, unpredictable results could sometimes be returned.  This problem has been fixed. 

SWIFT-243: Bug in pharm actions tags 
In the previous software, there was a bug that caused Pharmacological actions tags to not be appropriately 

applied in certain situations.  This has been fixed. 

SWIFT-226: Command-Q problem on Mac 
Previously, using Command-Q to quit the program on Mac computers would not prompt the user if they 

want to save their changes.  In addition, user changes to preferences were not save under this scenario.  This 

problem has been fixed. 

SWIFT-241: Problem with excel export: fails if cell contents > 
32000 chars 
Previously, exporting document lists to excel could fail when the contents of an individual cell exceeded 

32,000 characters.  For example, some documents may have very long author lists and go over this limit.  In 

the updated software, all fields will be automatically truncated at 32,000 characters. 
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SWIFT-179: Charts font not effected by font size option 
Previously, the fonts displayed in the Bar and Pie Charts views were not adjusted based on the user’s font size 

selection.  This has been fixed. 

Version 1.15, Build 1076: 5.23.2016 

SWIFT-229: Tag Browser Report 
You can now export the current selections in the tag browser to Excel to create detailed scoping reports.  For 

example: 

 

Step 1 
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Step 2 

 

 

 

 

Step 3 (Results) 

 



  Page 35 of 53 

SWIFT-228: Modify existing excel reports to allow combination 
In many cases, you can now automatically combine excel output from SWIFT-Review into a single 

spreadsheet using separate worksheets for each page in your “report.”  For example: 

Step 1 (Export tag heatmap) 

 

Step 2 (Choose existing Excel file) 



  Page 36 of 53 

Step 3 (Results appended as new worksheet) 

 

SWIFT-232b: SH:MH search 
You can now search using the subheading as a prefix, as in: 

mesh_mh:( “abnormalities.A07*” ) 

This enables the ability to search for any cardiovascular anatomy codes (A07*) that are tagged with the 

subheading “abnormalities.” 

SWIFT-236: Add Query Syntax Help and website link to Help 
menu 
The help menu now contains links to the SWIFT-Review website and to the query help documentation. 

SWIFT-234: Export to Excel - scores don’t match  
When exporting selected documents to excel, the search score previously didn’t match scores shown in the 

application. Bug has been fixed. 

SWIFT-230: Toggle Checkboxes very slow  
Clicking check all or uncheck all in the document list could previously take a very long time for large projects. 

Bug has been fixed. 

SWIFT-225: Problem with article type  
Previously, there was a problem with the article type tag.  Tagging was not working correctly for research and 

non-research article types. Bug has been fixed. 
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SWIFT-235: Export Data menu option not disabled  
Menu option has been changed to be disabled when no project is open 

SWIFT-237: Message box, progress bar icons cut off on Windows 
10  
Previously, icons such as the “i” shown below were being cutoff in Windows 10. Bug has been fixed. 

 
 

Version 1.14, Build 994: 3.10.2016 

SWIFT-233: New Endocrine Disrupting Chemicals Tag 
We added a new EDC Tag category.  You can use this category to filter by articles mentioning various 

endocrine disrupting chemicals: 
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Version 1.13, Build 979: 3.07.2016 

SWIFT-223c: Enhanced Tox21 Filters 
We revised the way the Tox21 Filters work.  Previously, Chemicals in the “Dual Use” category would also 

appear in the Pharmacological and Non-Pharmacological categories.  Now these three categories are 

mutually exclusive. 

 

SWIFT-225: New “Article Type” tag Category 
We added a new “Article Type” Tag category.  You can use this category to filter by Research Articles, Non-

Research Articles and Systematic Reviews: 
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SWIFT-232: Search for Mesh Term *plus* subheading 
Now you can create queries of the form mesh_mh:( heading:subheading ). 

SWIFT-217: “Close Project” 
You can now close open projects without closing the application (user request). 

SWIFT-173: Options – values sticking 
Fixed a bug where various options selected from Tools > Options were not propagating through the system 

properly. 

SWIFT-224: Export Tag Grid >> Export Tag Heatmap 
Slight reorganization of menu options in preparation for new upcoming reports features.  (Stay tuned!) 

Version 1.13, Build 938: 2.16.2016 

SWIFT-210: Upgrade to 2016 MeSH Tree 
There were some extensive changes to the 2016 PubMed MeSH Tree: 

https://www.nlm.nih.gov/pubs/techbull/nd15/nd15_medline_data_changes_2016.html 

We have changed the SWIFT-Review software to reflect these changes.  In addition, several of the MeSH-

based Health Outcome categories were simplified. 

The new 2016 tree will be used with newly created projects; previously created projects will continue to use 

the 2015 tree. 

https://www.nlm.nih.gov/pubs/techbull/nd15/nd15_medline_data_changes_2016.html
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SWIFT-223b: Enhanced Tox21 Filters 
Previously the updated Tox21 filters would only be available for newly created projects.  We have changed 

the software so that when old projects are loaded, they will be upgraded automatically to use the new filters. 

Version 1.13, Build 917: 2.8.2016 

SWIFT-222: Release History 
This document is now accessible from the help menu: Help > Release History. 

SWIFT-223: Enhanced Tox21 Filters 
There are now separate Tox21 filters available for Pharamacological, Non-Pharmacological and Dual use 

chemicals.  The pharmacological and non-pharmacological categories both also contain all of the chemicals in 

the dual use category. 

SWIFT-214: Turn on/off [No Tags] in bar charts 
Added Toggle [No Tags] option to bar charts like in pie charts. (User Request) 

SWIFT-182: Highlight color answer key in tag browser 
Previously, the highlighting colors were hard-coded in the tag browser, and there was no obvious signal 

which color corresponded to which tag browser column.  Now the highlight color is shown inside each 

browser column as a reminder.  Also, you can change the highlight colors by clicking these new buttons. (User 

Request) 
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SWIFT-203: Export Tag Grid Enhancement 
In response to a user request, it is now possible to limit the scope of the documents exported during the 

Export Tag Grid… operation.  In addition to choosing the column and the row tag categories, the document 

scope can also be limited to: all documents, visible documents or selected documents.  

SWIFT-202: Enhanced data export 
In response to a user request, you can now export document lists directly to Excel: 

• Select you documents in the document list. 

• Right click and choose “Export Selected…” 

• Choose Excel (.xlsx) as the file type 

 

Previously, the only option was exporting to a text file. 

SWIFT-181: Save Query as Tag 
A user requested a feature where after executing a query from the search box, they could tag the search 

results in such a way that they keywords matching the query will retain their highlighting in the search 

browser.  Now, from the search screen you can click “Tag search results…” and send either the entire search 

results or the current selection in the document list to a tag of your choice.  The highlighted search words will 

be reflected in the tag browser. 

 

SWIFT-204: Convert "Smart Quotes" 
Previously, the SWIFT-Review query engine could only understand quotation characters if they look like this: 

".  That is “straight-quotes”.  The problem is that Microsoft Word auto-magically changes straight-quotes to 

these characters: “”, which was causing problems when copy/pasting to/from MS-Word.  Now SWIFT-Review 

can handle both types of quotes. 

SWIFT-212: Preferences dialog "Save button" 

The “Save” button on the preferences dialog has been replaced by a “Close” button.  All changes are saved 

immediately. 

SWIFT-215: Error Message when Prioritizing 
Fixed a problem where prioritizing can give an error message when the total number of items in the list is less 

than 100. 
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SWIFT-166: Ranking with fewer than 20 seed documents / 
prioritize message confusing 
The software will now allow you to rank documents with as few as 10 total seed documents.  (We still 

recommend at least 20.) Also, reworded some error messages to make them less confusing. 

SWIFT-211: Pie Chart - add options to show percent or count 
For the Pie chart, the user can now select three options in the preferences panel to change the display: 

1. “Labels with percentage”  

2. “Labels with counts”  

3. “Labels only” 

Version 1.13, Build 780: 12.9.2015 

SWIFT-208: Tag Grid Export Bug 
A user reported the following bug, which has now been fixed: 

Tools > Export Tag Grid  

Choose "Tox21" Chemicals for Category 1 (Rows)  

When exporting the data to excel, the resulting file has 0 for all cells.  

Same for MeSH Publication types 

SWIFT-174: Options - Save buttons are not aligned 
Small cosmetic change 

SWIFT-196: Don't allow renaming or deletion of [No Tag] tag 
A user reported that problems are caused when they deleted the “[No Tag]” tag for a tag category in the 

browser.  This “special” tag should not be disabled or deleted, so we have disabled this functionality. 

SWIFT-200: Tag counts don't refresh 
Fixed the following bug: 

Open tagbrowser and go to health outcomes. change or delete some tags. choose tools > reset 

taggers (health outcomes). changes are not refreshed. 

SWIFT-201: Change Health Outcomes to use mesh 
To increase the precision of health outcome tagging in SWIFT, we have modified the tagging queries.  

Previously health outcome tags were applied using a set of high-ranking words mined from a random sample 

of MeSH articles.  Now, we have simplified the procedure such that health outcomes are applied using top-

level disease codes only, as follows: 
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Health Outcome Query 

Neoplasms mesh_mh:( C04.* ) 

Musculoskeletal Diseases mesh_mh:( C05.* ) 

Digestive System Diseases mesh_mh:( C06.* ) 

Stomatognathic Diseases mesh_mh:( C07.* ) 

Respiratory Tract Diseases mesh_mh:( C08.* ) 

Otorhinolaryngologic Diseases mesh_mh:( C09.* ) 

Nervous System Diseases mesh_mh:( C10.* ) 

Eye Diseases mesh_mh:( C11.* ) 

Male Urogenital Diseases mesh_mh:( C12.* ) 

Female Urogenital Diseases and Pregnancy Complications mesh_mh:( C13.* ) 

Cardiovascular Diseases mesh_mh:( C14.* ) 

Hemic and Lymphatic Diseases mesh_mh:( C15.* ) 

Congenital, Hereditary, and Neonatal Diseases and Abnormalities mesh_mh:( C16.* ) 

Skin and Connective Tissue Diseases mesh_mh:( C17.* ) 

Nutritional and Metabolic Diseases mesh_mh:( C18.* ) 

Endocrine System Diseases mesh_mh:( C19.* ) 

Immune System Diseases mesh_mh:( C20.* ) 

Wounds and Injuries mesh_mh:( C26.* ) 

Anxiety Disorders mesh_mh:( "F03.080.*" ) 

Delirium, Dementia, Amnestic, Cognitive Disorders mesh_mh:( "F03.087.*" ) 

Dissociative Disorders mesh_mh:( "F03.300.*" ) 

Eating Disorders mesh_mh:( "F03.375.*" ) 

Mental Disorders Diagnosed in Childhood mesh_mh:( "F03.550.*" ) 

Mood Disorders mesh_mh:( "F03.600.*" ) 

Schizophrenia and Disorders with Psychotic Features mesh_mh:( "F03.700.*" ) 

Sexual and Gender Disorders mesh_mh:( "F03.800.*" ) 

Sleep Disorders mesh_mh:( "F03.870.*" ) 

Substance-Related Disorders mesh_mh:( "F03.900.*" ) 

 

Keywords are still highlighted using the data-mined terminology. 

Version 1.13, Build 719: 11.18.2015 

Port Change: 443 instead of 8080 
Some institutions such as FDA and EPA are blocking port 8080.  We have released an update that allows the 

software to use port 443 instead, which seems to be allowed by most organizations. 
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Version 1.12, Build 712: 11.17.2015 

SWIFT-197: Conditional formatting and direct export of tag grid 
to excel 
Previously, the option “Tools > Export Tag Grid…” would output results in a tab delimited text file.  We have 

modified the software to send results directly to Excel with cells color-coded as a “heatmap” that indicates 

the relative number of articles corresponding to each cell. 

 

SWIFT-198: Export to RIS 
Now you can export ranked lists as .RIS files.  Basically, you just select documents visible in the document list 

(e.g. after selecting a Prioritized List and verifying it is sorted by Score descending).  Then select all 

documents in the list.  Right Click and choose “Export Selected”. 
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 When the dialog box comes up to ask you where to save the file, make sure to choose file type “Research 

Information Systems Citations file (.ris)” 

  

The resulting RIS file also includes a custom field (C1) that has the rank order of the document within the list.  

SWIFT-199: Batch Import PMID Lists 
Now, in the batch query feature, you can alternatively provide a list of PMIDs for each new tag in a text file 

instead of a Lucene query.  The format of the file is one PMID per line. 
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Initial Public Release - Version 1.11, Build 621: 10.03.2015 

SWIFT-118: New SWIFT Icon 
We finally have a professional quality logo and icon. Hooray! 

 

SWIFT-134: SWIFT-122 Tutorial 
A SWIFT-Review tutorial is now available.  You can access it from the application by clicking Help > Tutorial. 

SWIFT-135: SWIFT-122 Query Syntax Reference 
The software now contains an integrated query syntax reference. You can access it from the application by 

clicking the Query: (Help) link on the search page. 

SWIFT-195: Make Ranked Lists into a Navigation panel 
Previously, it was somewhat difficult to use the ranked lists in SWIFT-Review. To make the interface more 

intuitive, prioritized lists have been moved from the right side to left side along with the other navigation 

panels. In addition: 

• “Ranking Performance” tab was renamed to "Prioritized Lists"  

• This tab should only be enabled when one or more prioritized lists have been created  

• Changing the selection in the dropdown filters records in list and order them by priority score 

• When a new ranked list is created by the user, the Prioritized Lists tab is activated and the new 

list is made active. 

SWIFT-157: Build Topic Model: Unclear that something 
happened. 
When a user has successfully built a new topic model, they will now see a helpful message box telling them 

that the process is complete and where results can be found. 

SWIFT-194: Enable/Disable Charts when not applicable 
To streamline the workflow: 

• Bar Chart and Pie Chart views are disabled when user is not using Tag Browser.  

• Ranking Performance Tab is disabled when no ranked lists are available  

• All Tabs are disabled when the project is empty  

• The order of navigation (left) tabs has been changed: Tag Browser first, followed by Search, then 

MeSH tree 

https://api.sciome.com/SWIFTupdates/Tutorial/SWIFT%20Tutorial%20-%20v1.1.pdf
https://api.sciome.com/SWIFTupdates/Tutorial/Searching%20For%20Documents%20in%20SWIFT.pdf


  Page 47 of 53 

SWIFT-85: Merge the TermBrowser and Document Folders 
Views 
The “Document Folders” tab has been removed and its functionality has been subsumed by the “Term 

Browser” tab. 

SWIFT-153: Term Browser Irony 
Fixed several issues that have greatly improved the performance of the SWIFT Term browser. 

SWIFT-104: Performance Optimizations 
Several changes were made which drastically reduce the amount of memory required for SWIFT projects. 

SWIFT-120: Extract Term Browser Query 
A User has requested the ability to right click to view underlying query in the Tag Browser view.  It is now 

possible to choose “Copy Tag Browser Query” from the context menu.  The query can be pasted to the 

Search tab for examination or experimentation. 

SWIFT-106: Export Tag Grid 
A new feature was added that allows users export “heatmap” data consisting of document counts at the 

intersection of two tag categories: Tools > Export Tag Grid… 

SWIFT-109: Assign Tags from File 
Users can now right click in the tag browser to import a file containing list of PMIDs and folder names, and 

then automatically assign pmids to those folders.  

SWIFT-56: Check file formats when load. 
The software should now give an error message if the user tries to load data in the incorrect format.  

SWIFT-193: Export data overwrite 
When exporting data, a new sub-directory is now created based on the current date and time.  Previous 

behavior was to prompt the user if they wanted to overwrite the chosen directory.  Potentially dangerous! 

SWIFT-154: Progress Bar Delay 
Bug Fix: sometimes the progress bar did not show for a very long time when loading data. 

SWIFT-165: Document Preview - "all documents" not capitalized 
Small cosmetic fix. 

SWIFT-180: eBooks not loaded 
Fixed user-reported bug: PubMed “e-book” citations were not loading properly. 

SWIFT-155: Allow upload from XML file 
Users can now upload data from downloaded PubMed search results in XML format. 
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SWIFT-171: Corrupted Project File 
Fixed bug whereby project files can become corrupted. 

SWIFT-86: Remember search score for batch queries that 
become folders 
When running batch queries, the search scores are now saved. 

SWIFT-119: Normalize Search Scores 
Users have requested that Lucene Search scores be normalized from 0 to 1. 

SWIFT-53: Report missing PMIDS 
When loading data from PMIDs, previous behavior was to add a blank row if a PMID is missing from the 

database. Now, these PMIDs are excluded, but the user is shown a list of the missing PMIDS. 

SWIFT-149: "Save Project" menu option should be greyed out 
when project empty 
Small fix. 

SWIFT-150: Add % to Pie chart hover 
Small fix. 

SWIFT-152: Timeout on PMID load 
We have increased the timeout on PMID load to avoid problems during busy server load. 

SWIFT-132: Document Preview: Query Term Matches 
Query term hits are now shown in the browser instead of fingerprint matches.  
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Version 1.0 (Beta), Build 281: 7.30.2015 

SWIFT-117: Bar Graph View 
By user request, a new bar graph view has been added to complement the pie chart view. 

 

SWIFT-131: Pie Chart – Allow to Hide [No Tag] Slice 
The user can now right-click to choose whether or not they want to see the [No Tag] slice. 

SWIFT-147: Update Evidence Stream Query 
The evidence stream filter for ‘human’ has been changed to remove terms that are not human-specific. 

following change to the evidence stream search terms for the human filter.  

Version 1.0 (Beta), Build 280: 7.16.2015 

SWIFT-14: Options to re-run topic modeling and change 
parameters 
Users may now explicitly choose the number of topics when performing topic modeling.  In addition, users 

can now build topic models “on the fly,” using a user-selected subset of input records.  
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To re-run topic modeling, go to Tools > Build Topic Model… It will bring up a dialog that asks how many topics 

you want to use and for the name of a folder set to store the results.  If you choose “Topic Models” as the 

storage location, it will overwrite the automatically computed 50-Topic model.  But, you can create as many 

topic models as you want and store them in separate folder sets.  E.g. you could make a “Topic Models_25” 

to try out a 25-topic model.  You can also choose whether you want to include all documents in the model, or 

only the visible ones.  This allows you to, for example, select a particular set of health outcomes and build a 

topic model using only those documents. 

 

SWIFT-128: Change health outcomes "Other" to none 

SWIFT-129: Add "Other" category to the other tags (queries and 
health outcomes) 
We have added a “[No Tag]” item to the term browser.  If you select this, it shows all the documents that 

don’t match any of the other possible tags in the given category: 
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SWIFT-130: Exposure query tweak 
The General Environmental Exposures query has been modified and should no longer include documents that 

match one or more of the more specific environmental exposures.  

SWIFT-121: User Authorization 
In preparation for future functionality in which certain elements of project data may be stored remotely “in 

the cloud”, users will now be prompted to login in with an email address and pw upon starting SWIFT-

Review.  The software will remember these credentials, however, so it should not be overly burdensome 

after the initial log-in.  

SWIFT-139: Logging function doesn't work on Mac 
A bug has been fixed in which application logging (used only for debugging purposes) was not being saved 

properly on Mac computers. 

SWIFT-25: Wrong MeSH Terms 
Fixed a bug in which MeSH terms could be confused if browser columns are reordered. 

SWIFT-114: TermBrowser: Image icon and sorting 
Bug Fix: in the term browser, previously, if you changed the column order and move the image icon out of 

column 1 and then sort by column 1, an exception would be get thrown. 

SWIFT-138: Main Menu needs enable / disable check: i.e. grey 
out items when empty project 
Menu items are now greyed out when not available for use. 

SWIFT-126: Word cloud missing letter on phrases 
Bug fix: word clouds were missing the “type” letter – e.g. “abstract”, “title” etc for 2- and 3- gram phrases. 

SWIFT-101: Tag Browser Bugs 
Miscellaneous Tab Broser bugs have been fixed. 

Version 1.0 (Beta), Build 249c: 6.26.2015 

SWIFT-8: Auto updates now supported! 

SWIFT-6: About Box 
From time to time, the SWIFT-Review software will be updated to add new features and functionality.   
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You can check the current version of the software at any time by clicking Help > About from the SWIFT-Review 

menu: 

 

SWIFT-Review software updates are made available automatically using the following complementary 

mechanisms: 

• Minor Updates: In most cases, SWIFT-Review updates will happen automatically and will not require 

any user action. 

• Major Updates: Occasionally, a more comprehensive update may be offered.  In these cases, SWIFT-

Review will prompt you after start-up to let you know that a major update is available.  The upgrade 

will be optional, but if you choose to install it, you will need administrative privileges on your computer 

in order to run the installation package. 

SWIFT-12: Copy, Cut, Paste 
Copy/paste functionality is now available from most of the screens in SWIFT-Review including:  

• Tag Browser  

• Document List 

• Document Preview 

• Pie Chart 

• Word Cloud  

For example, you can copy a list of documents from the document and paste it into Excel for further analysis. 

To paste images such as the pie chart, you may have to use “Paste Special” and choose the image data type; 

otherwise, the pie data will be pasted as text. 

SWIFT-105: Load PMIDs via e-utils 
It is now possible to directly load data into SWIFT simply by importing a list of Pubmed IDs.  Choose File > 

Load PMIDs… and select the location of a .csv or text file.  For example, try the following: 

1. Download the example file, Transgenerational_small.csv from the following URL: 

https://api.sciome.com/SWIFTupdates/Tutorial/TransGenerational_small.csv 

This a text file containing a random subset of the PMIDs (about 1/10 of the data) from the full set of 

citations obtained during a preliminary literature search for studies pertaining to the 

https://api.sciome.com/SWIFTupdates/Tutorial/TransGenerational_small.csv
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transgenerational effects of various environmental exposures..  If you want to see the PMIDs, you 

can open the file in Excel or a text editor. 

2. To load the data, click File > Load PMIDs… and browse to the location of the file you just downloaded.   

3. Click Open. 

4. After a few moments you should see a progress bar indicating that the data is being loaded into SWIFT-

Review.  Depending on the size of your project and the speed of your computer this can take anywhere 

from a few seconds to several minutes.  Loading data from a PMID list will usually take longer than 

opening data from a SWIFT-Review project file because, in this case, the application has to download 

and pre-process all of the associated bibliographical data from the PubMed website. 

SWIFT-111: Pie Chart colors fixed for slices 
When showing a pie chart, the colors are associated with the slices sizes. But in some cases it is more useful 

to user if colors were tied with the slice names. Eg. health outcome 'cardiovascular disease' would be blue 

regardless of whether it was 1% or 99%. That way, when user is comparing different tag selections in the 

term browser it will be more apparent which items are changing in prevalence. This functionality can now 

optionally be enabled from the options menu by choosing “Lock pie chart colors to tag names” 

 

SWIFT-112: Truncated words in Pie Chart 
Previously, slice names are always truncated to a fixed number of characters in the pie chart. We have 

provided a mechanism to allow the user to specify the number of letters to use for pie chart labels. In 

addition, labels are never truncated in the name of the tool tip. 

SWIFT-13: Preferences Dialog, Tools, Help Menu Items 
These menus have been re-organized in a more logical manner. 

SWIFT-28: Why the lag when click back on Search tab? 
Bug Fix: previously, there was sometimes a noticeable lag sometimes when reactivating the search panel.  


